ADRIFT Forum


The place to discuss the ADRIFT Interactive Fiction toolkit

Load Graphics error: Object reference not set...

This forum is the place to learn about and discuss ADRIFT 5. Feel free to mention any bugs you find here, but please also add these to the Bugs & Enhancements list.

Please also refer to the ADRIFT 5 Wiki for more information.

Load Graphics error: Object reference not set...

Postby DazaKiwi » Tue Nov 19, 2019 1:46 am

Has anyone got this error before? "Load Graphics error: Object reference not set to instance of an object" this is the first time i've seen it. After this error message i still can access the object no problem.

It happens when i open up an object that i had an image loaded on to it in graphics tab. I tried another different jpeg image (which does display in the window) and it still throws this error. I tried adding another image to a different object and same thing. Weird. I closed down Adrift and opened up my project again but that didn't change anything.

I did a test and created a new adrift project and a new object and added an image to it, once again opening the object gives this error.
User avatar
DazaKiwi
 
Posts: 669
Joined: Thu Oct 21, 2010 9:05 am
Location: New Zealand
Points: 21

Re: Load Graphics error: Object reference not set...

Postby Lazzah » Tue Nov 19, 2019 8:02 am

DazaKiwi wrote:Has anyone got this error before? "Load Graphics error: Object reference not set to instance of an object" this is the first time i've seen it. After this error message i still can access the object no problem.

It happens when i open up an object that i had an image loaded on to it in graphics tab. I tried another different jpeg image (which does display in the window) and it still throws this error. I tried adding another image to a different object and same thing. Weird. I closed down Adrift and opened up my project again but that didn't change anything.

I did a test and created a new adrift project and a new object and added an image to it, once again opening the object gives this error.

I never use the graphics tab at all, if I want to display an image I put a link to it in the location or message text.
The Axe of Kolt, The Spectre of Castle Coris, The Fortress of Fear, Die Feuerfaust, The Lost Children, Run, Bronwynn, Run, The Call of the Shaman, The Lost Labyrinth of Lazaitch, Magnetic Moon, Starship Quest, Revenge of the Space Pirates
User avatar
Lazzah
Moderator
 
Posts: 2269
Joined: Thu Mar 31, 2011 4:54 am
Location: Dagenham, Essex
Points: 65

Re: Load Graphics error: Object reference not set...

Postby DazaKiwi » Wed Nov 20, 2019 8:41 pm

Yes that method word- but it was weird to me the error appears if i use the other method, as in the past if the tab method doesn't work the image just doesn't appear. Wondering if anyone else has had that error message before.
User avatar
DazaKiwi
 
Posts: 669
Joined: Thu Oct 21, 2010 9:05 am
Location: New Zealand
Points: 21


Return to ADRIFT 5.0

Who is online

Users browsing this forum: No registered users and 4 guests

cron