ADRIFT Forum


The place to discuss the ADRIFT Interactive Fiction toolkit

Trouble opening 5.0

This forum is the place to learn about and discuss ADRIFT 5. Feel free to mention any bugs you find here, but please also add these to the Bugs & Enhancements list.

Please also refer to the ADRIFT 5 Wiki for more information.

Trouble opening 5.0

Postby Lyricasylum » Fri Jan 24, 2020 9:44 pm

I am trying to download the latest link for the full 5.0 version. It tries to install, then gives me this error message:

"Microsoft .NET framework 2.0 SP2 needs to be installed for this installation to continue."

How do I remedy this? Thanks!
Lyricasylum
 
Posts: 82
Joined: Sat Jan 03, 2015 10:54 pm
Points: 10

Re: Trouble opening 5.0

Postby P/o Prune » Sat Jan 25, 2020 5:35 am

I had the same problem.
Had run V.5 without problems and then after an reinstallation of Win Edge, I got the same message you did.
Only thing there is to do is to download and install the 2.0 SP2
(That is, unless someone around here can come up with a better solution. :| )
D-Day in progress 86Kb (Slowly drifting)
Just a Fairy Tale: 138Kb
User avatar
P/o Prune
Site Admin
 
Posts: 4643
Joined: Mon Jun 24, 2002 8:18 am
Location: Denmark
Points: 93

Re: Trouble opening 5.0

Postby Lyricasylum » Sun Jan 26, 2020 5:48 am

I downloaded the file but now, even though the computer tells me it's installed, I can't locate it in the destination file.
Lyricasylum
 
Posts: 82
Joined: Sat Jan 03, 2015 10:54 pm
Points: 10

Re: Trouble opening 5.0

Postby P/o Prune » Sun Jan 26, 2020 6:18 am

Don't worry about the file. Just install V.5.
It worked for me.
D-Day in progress 86Kb (Slowly drifting)
Just a Fairy Tale: 138Kb
User avatar
P/o Prune
Site Admin
 
Posts: 4643
Joined: Mon Jun 24, 2002 8:18 am
Location: Denmark
Points: 93

Re: Trouble opening 5.0

Postby Lyricasylum » Mon Jan 27, 2020 3:53 am

I tried installing it again but it won't work. It goes through the installation process but when I try to run the app it gives me an error message. I even tried porting it to a USB drive from my previous computer and loading it onto my new computer but no dice.

I'm sorry to complain but I really have no idea why Version 5 works on my old computer but not my new one. Any advice would be appreciated. Thanks!
Lyricasylum
 
Posts: 82
Joined: Sat Jan 03, 2015 10:54 pm
Points: 10

Re: Trouble opening 5.0

Postby Lyricasylum » Mon Jan 27, 2020 4:47 am

NEVER MIND I GOT IT TO WORK! WOOHOO!
Lyricasylum
 
Posts: 82
Joined: Sat Jan 03, 2015 10:54 pm
Points: 10

Re: Trouble opening 5.0

Postby P/o Prune » Mon Jan 27, 2020 8:26 am

Lyricasylum wrote:NEVER MIND I GOT IT TO WORK! WOOHOO!

Good work.
What did you do?
D-Day in progress 86Kb (Slowly drifting)
Just a Fairy Tale: 138Kb
User avatar
P/o Prune
Site Admin
 
Posts: 4643
Joined: Mon Jun 24, 2002 8:18 am
Location: Denmark
Points: 93

Re: Trouble opening 5.0

Postby Lyricasylum » Mon Jan 27, 2020 11:37 pm

I just restarted my computer and tried it again.
Lyricasylum
 
Posts: 82
Joined: Sat Jan 03, 2015 10:54 pm
Points: 10

Re: Trouble opening 5.0

Postby Lyricasylum » Sun Jun 07, 2020 2:16 pm

It's happening again. The app isn't working. I tried downloading it again and installing it again and it keeps giving me error messages. Restarting the computer didn't help.
Lyricasylum
 
Posts: 82
Joined: Sat Jan 03, 2015 10:54 pm
Points: 10

Re: Trouble opening 5.0

Postby Lyricasylum » Sun Jun 07, 2020 10:18 pm

It's working on my older laptop; good thing I kept it!
I'd still like to see it working on this computer, though.
Lyricasylum
 
Posts: 82
Joined: Sat Jan 03, 2015 10:54 pm
Points: 10

Re: Trouble opening 5.0

Postby Lumin » Sun Jun 07, 2020 10:44 pm

Is it still the same error message?

I'd try reinstalling .Net 2.0 first of all:
https://www.microsoft.com/en-us/downloa ... px?id=1639

I'm using Windows 10 so I know it works with that anyway. (Which is good, because a lot of things don't...)
User avatar
Lumin
 
Posts: 2154
Joined: Fri Aug 06, 2004 5:48 pm
Points: 49

Re: Trouble opening 5.0

Postby Lyricasylum » Mon Jun 08, 2020 12:09 am

Thank you. Unfortunately, I tried all three files at that link and ADRIFT still won't work.
Lyricasylum
 
Posts: 82
Joined: Sat Jan 03, 2015 10:54 pm
Points: 10

Re: Trouble opening 5.0

Postby Campbell » Tue Sep 01, 2020 8:41 am

Which exact release do you have? ADRIFT no longer uses .Net Framework 2.0, so you might be on a very old release, or it might be an issue with the installer.
ADRIFT Developer developer.
User avatar
Campbell
Site Admin
 
Posts: 4709
Joined: Sun Jun 23, 2002 11:05 am
Location: Edinburgh, Scotland

Re: Trouble opening 5.0

Postby Lyricasylum » Sat Sep 05, 2020 3:12 am

Campbell wrote:Which exact release do you have? ADRIFT no longer uses .Net Framework 2.0, so you might be on a very old release, or it might be an issue with the installer.

It's been a while since I tried and I don't remember which version I tried to download. Can you provide me with a link to the version I should be using? Thanks!
Lyricasylum
 
Posts: 82
Joined: Sat Jan 03, 2015 10:54 pm
Points: 10

Re: Trouble opening 5.0

Postby Campbell » Thu Sep 10, 2020 9:39 pm

Latest copy is always here. ADRIFT currently uses .Net Framework 4.7.2.
ADRIFT Developer developer.
User avatar
Campbell
Site Admin
 
Posts: 4709
Joined: Sun Jun 23, 2002 11:05 am
Location: Edinburgh, Scotland

Next

Return to ADRIFT 5.0

Who is online

Users browsing this forum: No registered users and 2 guests