ADRIFT Forum


The place to discuss the ADRIFT Interactive Fiction toolkit

Exporting Folders- Folder disappeared but not its contents

This forum is the place to learn about and discuss ADRIFT 5. Feel free to mention any bugs you find here, but please also add these to the Bugs & Enhancements list.

Please also refer to the ADRIFT 5 Wiki for more information.

Exporting Folders- Folder disappeared but not its contents

Postby DazaKiwi » Sun Apr 17, 2016 9:24 am

I have noticed something odd when you create a module via export folder and you add several modules created this way to your library, it seems the last module in the list rather than remain in its folder gets filed away according to its entities, eg. a user function goes into the main User function folder, tasks in the task folder etc. If you swap the order around the other module has this happen to it.

Any ideas why this is happening? more of a question directed at Campbell i guess.

Its easier to keep your project tidy having modules in their own folders especially if you need to test modules working smoothly together in a project, so i do not know why this is happening. However, if these modules were manually imported in, no problem.

Do they have multiple custom modules (exported folder) in their library? Has anyone else notice this?
User avatar
DazaKiwi
 
Posts: 480
Joined: Thu Oct 21, 2010 9:05 am
Location: New Zealand

Re: Exporting Folders- Folder disappeared but not its conten

Postby ElliotM » Sun Apr 17, 2016 1:37 pm

I've not exported/imported multiple modules before, so I haven't seen this yet.
ElliotM
 
Posts: 1183
Joined: Tue Apr 17, 2007 8:04 pm
Location: The Midwest in the USA

Re: Exporting Folders- Folder disappeared but not its conten

Postby DazaKiwi » Sat May 28, 2016 3:17 am

I finally did a bug post about this problem, I almost forgot about doing that.

This bug might be local to exported folders only? the work around is only adding one exported module to your library and manually load the exported modules you want to use into your project.

http://www.adrift.co/bug/19103
User avatar
DazaKiwi
 
Posts: 480
Joined: Thu Oct 21, 2010 9:05 am
Location: New Zealand


Return to ADRIFT 5.0

Who is online

Users browsing this forum: No registered users and 3 guests

cron