The place to discuss the ADRIFT Interactive Fiction toolkit

Adrift 5.0 Linux/Mono not working

This forum is the place to learn about and discuss ADRIFT 5. Feel free to mention any bugs you find here, but please also add these to the Bugs & Enhancements list.

Please also refer to the ADRIFT 5 Wiki for more information.

Adrift 5.0 Linux/Mono not working

Postby Sparkcakes » Fri May 04, 2018 5:48 pm

Im really out of options

I installed Ubuntu , Linux Mint, Debian.
Correctly installed Mono package (complete), (also tried Wine and mono-wine plug-in as alternative)

Adrift 4.0 works fine using WINE

But as soon as i wanna run Adrift 5.0. It throws an “TargetParameterCountException”
Same happens on both native Linux mono and using WINE with mono-wine

I tried all kinda files , reinstalling mono, installing special mono addons, running as superuser.

Can anyone help me ?


EDIT : older version 5.0.33 works fine. But 5.0.34 and 35 both wont start at all
Posts: 1
Joined: Fri May 04, 2018 5:33 pm

Re: Adrift 5.0 Linux/Mono not working

Postby Campbell » Sun May 13, 2018 10:08 pm

I can't say offhand, I'd need to test this. If you have 5.0.33 working then just use that for now, and I'll do a test on Mono for the next release.
ADRIFT Developer developer.
User avatar
Site Admin
Posts: 4660
Joined: Sun Jun 23, 2002 11:05 am
Location: Edinburgh, Scotland

Re: Adrift 5.0 Linux/Mono not working

Postby supersmash2 » Wed Feb 13, 2019 6:48 pm

I have also the same error! How you solve it... :|
Super flash
Posts: 1
Joined: Wed Feb 13, 2019 6:25 pm
Location: NY

Re: Adrift 5.0 Linux/Mono not working

Postby along » Mon Apr 15, 2019 1:57 am

Is there any way to download prior versions of Adrift like 5.0.33? Thanks.
Posts: 1
Joined: Mon Apr 15, 2019 1:43 am

Re: Adrift 5.0 Linux/Mono not working

Postby R2T1 » Mon Apr 15, 2019 12:22 pm

Not sure what happened to the previous versions. I'm sure there used to be a link on the Downloads page. (It must have fallen off) Anyway, there is a version 5.0.31 available in the IF archive (link on links page) Or there is a 5.0.32 available via the Download Now button which will take you to Cnet.
User avatar
Posts: 137
Joined: Thu Dec 20, 2012 10:41 am
Location: Sydney, Australia
Points: 13

Re: Adrift 5.0 Linux/Mono not working

Postby rotter » Mon Apr 15, 2019 9:34 pm

This is a little depressing to read, when I know that loads of the non-ADRIFT world seem to use non-Windows.
Currently working on "The Blank Wall" in ADRIFT 5 and "Again and Again" in Inform 7.
Delron, the home of Otter Interactive Fiction.
User avatar
Posts: 1422
Joined: Sat May 08, 2004 12:12 am
Location: UK
Points: 20

Return to ADRIFT 5.0

Who is online

Users browsing this forum: No registered users and 11 guests