The place to discuss the ADRIFT Interactive Fiction toolkit

Adrift 5.0 Linux/Mono not working

This forum is the place to learn about and discuss ADRIFT 5. Feel free to mention any bugs you find here, but please also add these to the Bugs & Enhancements list.

Please also refer to the ADRIFT 5 Wiki for more information.

Adrift 5.0 Linux/Mono not working

Postby Sparkcakes » Fri May 04, 2018 5:48 pm

Im really out of options

I installed Ubuntu , Linux Mint, Debian.
Correctly installed Mono package (complete), (also tried Wine and mono-wine plug-in as alternative)

Adrift 4.0 works fine using WINE

But as soon as i wanna run Adrift 5.0. It throws an “TargetParameterCountException”
Same happens on both native Linux mono and using WINE with mono-wine

I tried all kinda files , reinstalling mono, installing special mono addons, running as superuser.

Can anyone help me ?


EDIT : older version 5.0.33 works fine. But 5.0.34 and 35 both wont start at all
Posts: 1
Joined: Fri May 04, 2018 5:33 pm

Re: Adrift 5.0 Linux/Mono not working

Postby Campbell » Sun May 13, 2018 10:08 pm

I can't say offhand, I'd need to test this. If you have 5.0.33 working then just use that for now, and I'll do a test on Mono for the next release.
ADRIFT Developer developer.
User avatar
Site Admin
Posts: 4620
Joined: Sun Jun 23, 2002 11:05 am
Location: Edinburgh, Scotland

Re: Adrift 5.0 Linux/Mono not working

Postby supersmash2 » Wed Feb 13, 2019 6:48 pm

I have also the same error! How you solve it... :|
Super flash
Posts: 1
Joined: Wed Feb 13, 2019 6:25 pm
Location: NY

Return to ADRIFT 5.0

Who is online

Users browsing this forum: No registered users and 7 guests