Page 1 of 1

Take Object from Character?

Posted: Mon Mar 16, 2020 11:07 am
by rovarsson
Hi all,

I ran my test macro of The Tree and got unexpected hostile responses from my main NPC when I tried to take his hat. I thought I had implemented rather friendly excuses why he would want to hold on to his clothing. Turns out I was overriding 'Take Objects from Location'. No problem, I'll change it to 'Take Objects from Character'. Except there is no such general task! Do I create my own? If so, how? Or is there another workaround?

Thanks.

Re: Take Object from Character?

Posted: Mon Mar 16, 2020 12:59 pm
by Denk
Before we can help you, we will need to know which library you are using. If you are using the default library of the newest official ADRIFT version (version 5.0.35.3), the default response is something like this: "The rifle is not on or inside another object!"

If you have updated the library to saabie's library, you will get something like this:
"John grabs your wrist and stops you from taking the rifle!"

In saabie's library there is a general task named "Take Objects From Character", which can be overridden.

From your description above, it sounds like you have updated to saabie's library, since saabie's response sounds hostile, whereas the response of v5.0.35.3 is not really hostile. If this is the case, something has gone wrong if you cannot find a "Take Objects from character"-task.

If you haven't updated the standard library, you can try to update the library but make sure to make a backup of your game first, in case something goes wrong.

When I know what is going on, it will be easier to help you.

Re: Take Object from Character?

Posted: Mon Mar 16, 2020 1:40 pm
by rovarsson
The hostile response is not from saabie's Library, it's because TAKE HAT goes against the restriction 'Object must no be worn by Character'. I get " %character1% looks at you and says: "You can't just take that.""

I'm using the default Library.