The place to discuss the ADRIFT Interactive Fiction toolkit

Object reference error... - Cannot save my work

This forum is the place to learn about and discuss ADRIFT 5. Feel free to mention any bugs you find here, but please also add these to the Bugs & Enhancements list.

Please also refer to the ADRIFT 5 Wiki for more information.

Postby DazaKiwi » Mon Dec 13, 2010 9:34 am

I get this error when i try to save my work.
"Object reference not set to an instance of an object".

*Sorted now but mystery as to what gave the error was not solved.*

I tried looked at the stack trace for any clues..

Code: Select all

   at . ..ctor(String sErrorMessage, Exception ex)
   at ADRIFT.Global.
(String sMessage, Exception ex)
   at ..
(String sFilename, Boolean bCompress, Int64 lLength)
   at ..   ()
   at ..
(String , String , String )
   at ..
(Object , ToolClickEventArgs )
   at Infragistics.Win.UltraWinToolbars.UltraToolbarsManager.OnToolClick(ToolClickEventArgs e)
   at Infragistics.Win.UltraWinToolbars.UltraToolbarsManager.FireEvent(ToolbarEventIds id, EventArgs e)
   at Infragistics.Win.UltraWinToolbars.ButtonToolUIElement.DoClickProcessing(MouseEventArgs e)
   at Infragistics.Win.UltraWinToolbars.ButtonToolUIElement.OnMouseUp(MouseEventArgs e)
   at Infragistics.Win.ControlUIElementBase.ProcessMouseUpHelper(Object sender, MouseEventArgs e)
   at Infragistics.Win.ControlUIElementBase.ProcessMouseUp(Object sender, MouseEventArgs e)
   at Infragistics.Win.Utilities.ProcessEvent(Control control, ProcessEvent eventToProcess, EventArgs e)
   at Infragistics.Win.UltraControlBase.OnMouseUp(MouseEventArgs e)
   at Infragistics.Win.UltraWinToolbars.UltraToolbarsDockArea.OnMouseUp(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
   at System.Windows.Forms.NativeWindow.DefWndProc(Message& m)
   at Infragistics.Win.UltraWinToolbars.UltraToolbarsDockArea.DockAreaSubClasser.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
   at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods

.IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
   at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun()
   at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()
   at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(String[] commandLine)
   at ..
(String[] )

There doesn't happen to be a error report file that gets written and saved anywhere?

Would be nice if the offending object in question is named.

I cannot work out which object its talking about.

I cannot save my work to send it to get looked at.

When i test run my game, it asks me if i want to save first. I choose no. The game runs but it seems to be running the previous incarnation of my game where I had a an event running a task too early (no objects involved there).

So i fixed that. But i still get the same task running when it shouldn't, and uncorrect description. Perhaps when you save your work then run the runner it either runs it from the saved file or it updates whatever changes were made.

I will have to leave my computer running over night, as not to lose any work and hopefully I figure it out. I dont want to start delete/cutting away things to work out whats wrong. I have done what with the few objects i have copy/cut and paste back when error still appears.

I can't recall what i did, as this error only appears when i save.

Any ideas. I guess unless you can see the whole thing i cant get much help on it. But the error message meaning could be expanded upon to enlighten me.

What does it mean by "not set to an instance of an object"?

**update **

I decided to risk it and close it down and restart it, since it seems there wasnt alot changed since last successful save.
And i did what i did before and i can save now. So i dont know what happened.

Edited By DazaKiwi on 1292237151
User avatar
Posts: 704
Joined: Thu Oct 21, 2010 9:05 am
Location: New Zealand
Points: 21

Return to ADRIFT 5.0

Who is online

Users browsing this forum: No registered users and 1 guest