Error: "Input past end of file", despite UK settings

This forum is the place to discuss the older ADRIFT versions 3.9 and 4.0.

Please refer to the ADRIFT 4 Manual for more information.
Post Reply
Posts: 1
Joined: Tue Mar 25, 2014 7:55 am

Error: "Input past end of file", despite UK settings

Post by paxwax »

Hello all!

I'm trying to play some adrift 4.0 adventures, but I met a problem. I've tried to install Adrift 4.0 on my (Windows Vista SP2) laptop. It installs fine, but when I try opening an adventure, after a long loading (several minutes), I get the message: "Error loading adventure - [Input past end of file,62,8]".

I did my homework before posting and read the manual associated with Adrift 4.0 on your website. It told me that this error is linked to my regional settings for non-Unicode programs being set in a foreign language. Sure enough, it was set in Chinese (I'm learning Chinese).

As prescribed, I set it back to English (UK): control panel --> regional and language options --> Administrative tab --> Language for non-Unicode programs --> Change system locale --> English (UK). Computer restarted.
I tried to load an adventure: same error message! I tried another adventure: same problem.

I uninstalled Adrift, reinstalled it: again, same error message! I also tried uninstalling Adrift, erasing any mention of it in the registry (Regedit, then search for "adrift" and delete all the related keys), then reinstall the software: no effect.

I get the feeling that despite the fact I changed back to English (UK) regional settings in my control panel, some registry key (unfortunately used by Adrift) did not record the change properly.

Anyway, I'm pretty lost. Anybody could help?
Many thanks!
Post Reply