ADRIFT Forum


The place to discuss the ADRIFT Interactive Fiction toolkit

Subscript error ?

This forum is the place to discuss the older ADRIFT versions 3.9 and 4.0.

Please refer to the ADRIFT 4 Manual for more information.

Postby cypher_x » Fri Mar 18, 2011 6:04 am

I was working in the Adrift 4.0 generator when I decided to run the game and alpha test the new changes.

The runner gave me an error, I don't remember the exact wordings but it was something like:

subscript error 9,10

I figured it might be related to the out of memory error so I just closed the runner and tried to run the game again and again and I continued to get the same subscript error.

I saved (a big mistake) and closed the generator thinking maybe I needed to reopen it fresh. I did and when I opened my WIP in the generator it was missing all the characters, events and some tasks at the bottom of the task list. :oh-no:

Luckily I always save my work on a jumpdrive so only lost about 2 hours work. Could have been much worse.

Does anyone know what causes this error? I would really like to avoid it again in the future if at all possible! :O
CyPheR_X
User avatar
cypher_x
 
Posts: 16
Joined: Wed Aug 18, 2010 3:02 pm
Location: Lands of Adventure
Points: 10

Postby Campbell » Fri Mar 18, 2011 12:21 pm

If you send me the file that errors, I'll take a look and see what the problem is.
ADRIFT Developer developer.
User avatar
Campbell
Site Admin
 
Posts: 4618
Joined: Sun Jun 23, 2002 11:05 am
Location: Edinburgh, Scotland

Postby cypher_x » Fri Mar 18, 2011 8:36 pm

Thank for the offer of help Campbell but I have accidentally found out what caused the error.

Seems when I try to cut a block of description from the ALR and paste it to a task's restriction text box it jumbles the description up with some
symbols in the lines. Then I get the subscript error 9,10 when trying to run the game immediately after.

Fixing the text won't work. I found I had to cut and paste to a word processor then cut and paste to the task restriction and everything worked fine.

Kinda odd but I know what causes the error now.
CyPheR_X
User avatar
cypher_x
 
Posts: 16
Joined: Wed Aug 18, 2010 3:02 pm
Location: Lands of Adventure
Points: 10


Return to ADRIFT 3.9 and 4.0

Who is online

Users browsing this forum: No registered users and 6 guests

cron