ADRIFT Forum


The place to discuss the ADRIFT Interactive Fiction toolkit

Desperate call for help

This forum is the place to discuss the older ADRIFT versions 3.9 and 4.0.

Please refer to the ADRIFT 4 Manual for more information.

Desperate call for help

Postby phkb » Thu Nov 17, 2011 2:29 am

I'm working on post-Comp updates to "Cursed", and I've hit a snag:
"Error loading adventure - [Input past end of file,62,11]"

If I clear the ALR and rerun the game, everything works fine (well, apart from none of the text replacements are in place).

I've tried putting the ALR in piece by piece, but I can't seem to identify any particular item that is causing problems. The ALR is currently 9757 lines long.

I'd really appreciate some suggestions here. This would be pretty deal-breaking if I can't fix it.
My IF-related stuff can be found here
User avatar
phkb
 
Posts: 376
Joined: Thu Jan 06, 2005 3:27 am
Location: Sydney, Australia

Re: Desperate call for help

Postby phkb » Thu Nov 17, 2011 3:36 am

It's now officially worse! Now when I open the file in Generator I'm getting the "Input past end of file" error. Doom! Disaster! Help!
My IF-related stuff can be found here
User avatar
phkb
 
Posts: 376
Joined: Thu Jan 06, 2005 3:27 am
Location: Sydney, Australia

Re: Desperate call for help

Postby phkb » Thu Nov 17, 2011 3:39 am

OK, saved by the backup file...but this is starting to freak me out.
My IF-related stuff can be found here
User avatar
phkb
 
Posts: 376
Joined: Thu Jan 06, 2005 3:27 am
Location: Sydney, Australia

Re: Desperate call for help

Postby Campbell » Thu Nov 17, 2011 8:24 am

The error does suggest it is to do with the ALR. Could you send it to me and I'll see exactly what's going wrong?
ADRIFT Developer developer.
User avatar
Campbell
Site Admin
 
Posts: 4570
Joined: Sun Jun 23, 2002 11:05 am
Location: Edinburgh, Scotland

Re: Desperate call for help

Postby David Whyld » Thu Nov 17, 2011 9:13 am

I had a similar error a while back which I think stemmed from my typing my game initially in Word then copying and pasting into the ALR. Somewhere along the way, something went wrong. When I finally tracked down what it was, it turned out to be a single character which in Word showed up as an extra space but in the ALR showed up as a square box. When I deleted the extra space/square box, it worked fine.
David Whyld
 
Posts: 6592
Joined: Sat Dec 18, 2004 5:15 pm
Location: United Kingdom

Re: Desperate call for help

Postby phkb » Thu Nov 17, 2011 9:20 pm

OK, Campbell, you should have an email with a ZIP file in your inbox.
My IF-related stuff can be found here
User avatar
phkb
 
Posts: 376
Joined: Thu Jan 06, 2005 3:27 am
Location: Sydney, Australia

Re: Desperate call for help

Postby phkb » Sat Nov 19, 2011 2:55 am

Campbell, thanks for doing a test for me. I have no idea why it now works, when nothing would appear to have changed. I don't know how many times I loaded the ALR, ran the game, hit the problem. Yet doing it now is fine. Weird...
My IF-related stuff can be found here
User avatar
phkb
 
Posts: 376
Joined: Thu Jan 06, 2005 3:27 am
Location: Sydney, Australia

Re: Desperate call for help

Postby Campbell » Sat Nov 19, 2011 9:21 am

Yeah, that is odd. Well if happens again don't hesitate to fire it across.
ADRIFT Developer developer.
User avatar
Campbell
Site Admin
 
Posts: 4570
Joined: Sun Jun 23, 2002 11:05 am
Location: Edinburgh, Scotland


Return to ADRIFT 3.9 and 4.0

Who is online

Users browsing this forum: No registered users and 6 guests

cron