Summer Comp Reviews

A forum where new and old games can be reviewed - an alternative to the reviews on the Adventures page of the main ADRIFT site. Also the place to ask for any assistance if you are stuck playing a particular game.
Post Reply
David Whyld
Posts: 7007
Joined: Sat Dec 18, 2004 5:15 pm
Points: 35
Location: United Kingdom

Post by David Whyld »

Well, the comp’s been over and done with for a few weeks and I've finally got around to writing my (short-ish) reviews of the games. Maybe it’s just me but I found myself struggling to continue with some games that seemed buggy, poorly written or just plain flawed. I actually quit playing Light Up upon discovering that BREAK WINDOW worked but SMASH WINDOW didn't, but then made myself go back to it later after telling myself that I was making a mountain out of a molehill. But this sort of flaw seemed indicative of a lot of the entries: commands that should have worked didn't and returned confusing error messages. Not so much because of flaws in the ADRIFT system itself (although the confusing error messages don't help), but simply because the authors didn't even think to cover more than the absolute bare minimum of responses. After all these years, it’s disappointing to find people still making the same mistakes. Guess the verb puzzles over the PUSHing or PRESSing of buttons are never fun.

Most of the games I didn't play through to completion so my reviews are based on the parts I did play, generally at the point I gave up after feeling I’d satisfied myself that the game wasn't worth me continuing with any longer. If the game improves dramatically later on, my apologies to the authors concerned for hammering their games, but if you want people to play beyond the first few locations you really need to give them an incentive to play. Typos, grammatical errors, bugs and whatnot don't give any incentive but to quit.

Reviewed in the order I played them:

Camelot by Finn Rosenløv

A few errors right there in the intro – general Secretary of the UN? Shouldn't that be Secretary General? Paragraph spacing also seems a little off – why not leave a line between paragraphs or indent the first line so it stands out? As it is, they all seem jumbled together. Item descriptions are poorly written. This is the desk:


Five sentences split over five paragraphs. Wouldn't it have been better to keep them all together in one paragraph? But the above is typical of the game and makes reading anything longer than a few words quite jarring.

Many other typos – Counsil instead of Council – meant the overall standard of writing fell a long way below what I’d call acceptable. English might not be the writer’s first language, but it’s still hard to recommend a game like this.

The game itself didn't exactly seem enthralling. The intro was poorly written and did a poor job of setting the scene. An intro needs to grip you and make you want to play the game. This intro just had me writing up a veritable shopping list of things that were wrong with it.

Anyway, not expecting much, I persevered. I got myself out of the cellar without too much trouble but then I wandered back and found that the exit had mysteriously disappeared; despite being informed that there was an opening in the wall, I wasn't able to go through it.

There were then more annoyances – a book that can’t be read while standing up but can while you're sat at a desk. The default error message of YOU CAN’T READ THE BOOK! is a little unfortunate here. (Incidentally, ‘read it’ doesn't work when referring to the book.) Here I was plunged into darkness and found myself in an unwinnable situation as I’d already used all the matches and thus had to start again. Probably my own dumb fault for lighting all the matches already for no other reason than they were there but it would have been nice if the game had warned me about this beforehand or at least given me an alternative light source. After a quick restart, I found myself magically transported to the kitchen of Castle Camelot... and a room description, complete with dialogue and an annoying pause and screen clearing, which repeats itself every type you type LOOK. How on Earth was this missed during testing?

At that point, I decided enough was enough. Sorry. While the game might boast no less than five testers, it’s so rough around the edges that it’s hard to believe it was tested at all. The three locations I saw were so buggy I could write an essay on the subject.


Just Another Day by Simply Ryan

The intro reads: “This is a game with no story, no direction, and no instruction. This is a game meant to make a statement in the world. It is suggested that the map is at the top of the screen.”

Hardly the sort of intro to inspire confidence. This was the second game I tried and neither had a decent intro.

I played for a few minutes and then concluded that my initial assessment of it being a waste of time was correct. A peek in the Generator reveals 27 locations and 25 tasks crammed into a measly 3 Kb. 3Kb? Yep. I've written introductions longer than that!

For what it’s worth, the game seems to comprise aimless wandering from one empty location to another with no attempt at depth or storyline along the way. What statement the author is trying to make I'm not sure – one that he doesn't know how to write a good game perhaps?

One to avoid.


Note: And, added to the above, the game was disqualified from the comp for plagiarism. The most surprising thing about this isn't that it’s plagiarised, but that someone would bother to plagiarise such an awful game. Surely there are good games out there that could be shamelessly ripped off instead?

Motion by Abbi Park

Well, this was certainly unusual. A text adventure that wasn't a text adventure at all but a kind of ASCII game where you move a rocket up and down the screen by pressing ENTER or add fuel by pressing F. A nice enough idea, and definitely not what I expected, but I can’t say it really worked that well. The game recommends I use Arial 12 and have the ADRIFT Runner in full screen mode – both of which I did and yet I still had the display hanging off the bottom of the screen. Clearly the writer had a bigger screen than me. The display also seemed messed up at times with parts of the rocket either disappearing or appearing slightly to one side of where they should have been.

So... not a text adventure at all and not very well done, but an interesting use of ADRIFT.


Pirate’s Plunder! by Tiberius Thingamus

The comp hadn’t got off to a good start – one buggy game, one bland act of plagiarism, and one text adventure that wasn't really a text adventure at all – but here things began to take a turn for the better. I'm not sure the mangling of the game’s text into pirate lingo – lots of “ye” and “looketh” and the like – would have retained its charm over the length of a larger game, but here it was in no danger of overstaying its welcome.

The writing was much, much better than in any of the other games so far, the storyline more interesting, and the puzzles nicely done. I batted my head against some for a while, then the light of understanding dawned and I figured out what I needed to do to solve them. There was an actual sense of achievement when I did this.

Overall, it was a fairly close run thing between this and Aegis for best game in the comp, with this edging slightly ahead due to the game-breaking bugs in Aegis.


Light Up by TDS

One of my pet peeves are games that blindly assume the player will know a specific item is present without ever directly referring to it. A while ago I played a game where an item was hidden under a door mat which was never referred to. This game has a similar ‘puzzle’ – and I put puzzle in quotes because it’s not so much a puzzle as it is a case of guessing what the author was thinking. The key item here needs examining to learn the password to the laptop, but it’s the only part of the car you can examine. Why can’t I examine the wheels, the roof, the bonnet, etc? For that matter, why oh why would anyone think to examine the licence plate to guess the password for the laptop anyway?

But that’s not the only hard ‘puzzle’ in the game. Try as I might, I can’t imagine how anyone could be expected to figure out the combination needed for the device in the cellar without consulting the hints. Or maybe I'm just getting worse at these games as I get older and senility sets in.

The game uses ADRIFT’s built-in help menu, which unfortunately is as flawed as ever. I'm informed of the existence of the laptop long before I actually found it, which involved a mini-game in itself as I hunted feverishly for said laptop knowing it was required at some point. Maybe that's my own fault for using the hints, but shouldn't I at least have seen the laptop before being informed of a hint about it? The hint about the laptop is actually visible in the first location, despite the fact that it’s impossible to obtain said laptop at that stage. I can also UNDO immediately after using the help menu and restore any points lost this way, thus rendering the penalty kind of pointless.

There were a few guess the verb problems. SMASH WINDOW won’t work but BREAK WINDOW will. Why not both? Commands that I felt should have worked didn't and there were quite a few times when ADRIFT’s default responses were jarring and out of context with the rest of the game. (The latter isn't really the author’s fault, but he could have provided overrides to make the responses a little better.)

Light Up jumps from scene to scene, first of all a house where the protagonist’s son is (so he believes) staying (or held captive), to a field where a conveniently placed gas mask prevents him from dying, to a prison cell where he dies, as I did, if he can’t figure out how to stop a bomb exploding. There seems little reason for the constant shift in location. Perhaps an explanation is coming at the end but after dying repeatedly in the prison cell, I decided to call it a day. After a mildly promising introduction, the game went rapidly downhill. Given the choice between a straightforward adventure game and the weirdness this became after the first scene, I’d have gone for the former any day.


Ba’Roo! by Hensman Int’l

Another of my pet peeves: games that don't accept perfectly reasonable commands. Here PRESS RED BUTTON works but PUSH RED BUTTON doesn't. Grrrr. Even more annoying are games that kill you without the slightest warning. Why have the black button kill you? Why not warn the player? Was there some way of guessing I’d be instantly killed if I happened to press this button? And, to be honest, it’s a button. Of course someone is going to push it. (Or press it. Whatever.)

After a rushed introduction – which had all the warmth and emotional impact as my shopping list – I'm dropped into a dark location where I can’t move. This isn't the best way to start a game I've ever come across. After much messing around with a series of buttons, I found a niche and succeeded in well and truly breaking the game. It seems that if you keep on pressing the silver pad, as I did because I wasn't sure what else to do, you get a whole bunch of error messages. Ouch. Pressing the gold pad repeatedly informs me that BOTH THE SILVER AND GOLD TOUCH PADS FADE AWAY. THE WEAPON4 BECOMES SOLID AND SITS IN THE NICHE. The WEAPON4? Ouch again.

Opening up the Generator reveals some excruciating task construction. I quite often came across things like [THROW/TOSS] {CERIMONIAL} KNIFE [AT/TO/TOWARD] [WIZARD/OLD MAN] (yes, complete with the misspelt word) and [TAKE/GET] [{RECTANGULAR} NICHE/{RECTANGULAR} HOLLOW/{GOLD/SILVER} {TOUCH} PAD] when, for the second, a simple GET * PAD * and a few synonyms would have sufficed.

My initial impression of the game was that it hadn’t been tested anywhere near as thoroughly as it needed to be and I really didn't feel any desire to play through the rest of it. The fact that it regularly killed me off – and hit me with ADRIFT’s godawful end game sequence (please, please, please override this or don't kill the player at all) – just made matters even worse.


Aegis by Lumin

For the most part, Aegis doesn't play like a standard text adventure. Commands are often highlighted in the text, cluing you into what needs doing, though in truth most of what needs doing isn't hard to figure out on your own. This is the closest to a CYOA game I've played that doesn't actually have numbered options at the end of each section. It was surprisingly fun to play, though. Informing the player upfront what needs doing might take away some of the point of a text adventure – i.e. figuring out the puzzles and what to do on your own – but it also freed Aegis from the painful guess-the-verb issues that plagued a number of the other entries.

It wasn't, however, without its problems. Just when I was beginning to suspect this might be the best game in the comp, I ran into several unfortunate, and game-breaking, errors (though no one else seems to have mentioned these so either I'm especially good at finding unfortunate and game-breaking errors or they don't occur all the time). The first of these involved me going to the docks to arrest some thieves, only to find they weren’t there. Upon attempting to leave the docks area, I was prompted by the game to arrest the thieves. For the heck of it, I typed ARREST THIEVES and, lo and behold, I arrested them, despite not even being able to see them at the time. By the look of things, a few paragraphs of text were missing here as the game implied that I was annoyed at one of the thieves getting away, which certainly didn't happen. The error played out further on when I was given a mission by Elder Hanawi, attempted to carry it out and mysteriously found myself at the docks again, even though I’d flown away in the opposite direction. This time the thieves were present and I was able to fight them, but upon attempting to arrest them again, I couldn’t. It seems the task is non-repeatable.

Later on, I managed to arrest the thief who had escaped, one Havasa, locked her up in a cell... and found it quite surprising that when I visited the marketplace later, she was still there arguing with a boat seller. The other thieves, the ones I’d previously arrested, were likewise still at the docks. My drake mount, Oxblood, also seemed a little bugged and would often appear in several different locations at the same time.

Errors aside – and they are pretty major ones, unfortunately – Aegis was the only game in the comp aside from Pirate’s Plunder that I felt was actually worth playing. Overall it’s probably a better game than Pirate’s Plunder, but the bugs are kind of hard to ignore, and thus leave it with a final score of


I’d certainly like to play more games in this vein, though. Less interactive than other games, maybe, but a lot more fun, too.

Edited By David Whyld on 1302297297
Posts: 444
Joined: Sat Aug 05, 2006 10:11 pm
Location: Canowindra, NSW

Post by revgiblet »

I've missed you, David.
"He who lives only to benefit himself confers on the world a benefit when he dies."


In Progress:- Watch This Space...
Posts: 523
Joined: Wed Sep 27, 2006 11:58 pm
Points: 10
Location: UK (was US)

Post by alsnpk »

David Whyld wrote:The game recommends I use Arial 12 and have the ADRIFT Runner in full screen mode – both of which I did and yet I still had the display hanging off the bottom of the screen. Clearly the writer had a bigger screen than me. The display also seemed messed up at times with parts of the rocket either disappearing or appearing slightly to one side of where they should have been.
Hmm. I hadn't heard anyone else say it didn't display correctly (as long as they ran it in full screen... if not full screen, it did have issues). What size screen/resolution do you use in case I want to fix this issue?
For competitions: Business As Usual; Oh, Human; Existence (intro); Motion
Shared names demo: "Guys, Guys"

Works in various stages of progress:
Y'know, things and stuff...
David Whyld
Posts: 7007
Joined: Sat Dec 18, 2004 5:15 pm
Points: 35
Location: United Kingdom

Post by David Whyld »

It was on my works computer (during dinner break, boss, in case you're reading this!) with a resolution of 1024*768 and a 17" screen.
Post Reply