ADRIFT Forum


The place to discuss the ADRIFT Interactive Fiction toolkit

Avira sees a virus in 5.0.35.2's run500 and dev500

This forum is the place to learn about and discuss ADRIFT 5. Feel free to mention any bugs you find here, but please also add these to the Bugs & Enhancements list.

Please also refer to the ADRIFT 5 Wiki for more information.

Avira sees a virus in 5.0.35.2's run500 and dev500

Postby Nimdok » Wed Jun 08, 2016 8:45 pm

Like the subject says, Avira (most recent libraries) picks up both as having the Dropper.MSIL.Gen2 trojan. Just wanted to let folks know, since there has been some problems in the past with false positives and such.
Nimdok
 
Posts: 4
Joined: Mon Feb 10, 2014 6:24 pm

Re: Avira sees a virus in 5.0.35.2's run500 and dev500

Postby ElliotM » Wed Jun 08, 2016 9:55 pm

How about with version 5.0.35.3? There was a patch yesterday.
ElliotM
 
Posts: 1227
Joined: Tue Apr 17, 2007 8:04 pm
Location: The Midwest in the USA
Points: 13

Re: Avira sees a virus in 5.0.35.2's run500 and dev500

Postby Nimdok » Wed Jun 08, 2016 10:33 pm

Yup.
Attachments
Untitled.png
Screenie of the report
Untitled.png (39.27 KiB) Viewed 5041 times
Nimdok
 
Posts: 4
Joined: Mon Feb 10, 2014 6:24 pm

Re: Avira sees a virus in 5.0.35.2's run500 and dev500

Postby ElliotM » Thu Jun 09, 2016 3:09 am

Good to know. I use BitDefender and I haven't had false positive problems with it so far.
ElliotM
 
Posts: 1227
Joined: Tue Apr 17, 2007 8:04 pm
Location: The Midwest in the USA
Points: 13

Re: Avira sees a virus in 5.0.35.2's run500 and dev500

Postby Lazzah » Thu Jun 09, 2016 7:10 am

Neither Avast on my home PC, nor Norton on my work laptop, report any infections in these two applications when scanned.
WIP: The Lost Labyrinth of Lazaitch

ALSO AVAILABLE: The Axe of Kolt, The Spectre of Castle Coris, The Fortress of Fear, Die Feuerfaust, The Lost Children, Run, Bronwynn, Run, Magnetic Moon, Starship Quest, Revenge of the Space Pirates
User avatar
Lazzah
Moderator
 
Posts: 2248
Joined: Thu Mar 31, 2011 4:54 am
Location: Dagenham, Essex
Points: 60

Re: Avira sees a virus in 5.0.35.2's run500 and dev500

Postby DazaKiwi » Thu Jun 09, 2016 7:14 am

I use Norton Anti-virus and get both of them flagged as well when i go to run them after updating Adrift, but I am able to restore them and tell Norton to ignore them.
User avatar
DazaKiwi
 
Posts: 643
Joined: Thu Oct 21, 2010 9:05 am
Location: New Zealand
Points: 21

Re: Avira sees a virus in 5.0.35.2's run500 and dev500

Postby P/o Prune » Thu Jun 09, 2016 7:25 am

Using Avast on my pc, no problems. I even ran a second scan just to make sure.
D-Day in progress 86Kb (Slowly drifting)
Just a Fairy Tale: 64Kb
User avatar
P/o Prune
Site Admin
 
Posts: 4423
Joined: Mon Jun 24, 2002 8:18 am
Location: Denmark
Points: 58

Re: Avira sees a virus in 5.0.35.2's run500 and dev500

Postby Campbell » Thu Jun 30, 2016 5:25 pm

It's frustrating. It's the software I use to package ADRIFT that's causing the false positives. My guess is the same software has been used by writers of viruses and so it has similar signatures. Rest assured, ADRIFT is clean. However, I think I will try to find a different packager for the next release.
ADRIFT Developer developer.
User avatar
Campbell
Site Admin
 
Posts: 4654
Joined: Sun Jun 23, 2002 11:05 am
Location: Edinburgh, Scotland


Return to ADRIFT 5.0

Who is online

Users browsing this forum: No registered users and 4 guests